Applicom's Blog

Product updates, news & miscellanea from your fellow Apollo developers.

This blog has moved! Head to the Building Apollo blog »

Andrea Di Clemente's picture
By Andrea Di Clemente
Monday, August 9, 2010 - 20:39

Why we will nag Apollo users on IE7 and IE8... forever

A few users pointed out that they are getting a strange warning: if they use something “quite recent” like Microsoft Internet Explorer 8, when they log into Apollo they get a big warning telling them to upgrade to a better and faster browser.

It reads like this:

You are using Internet Explorer 8. While we do support it, you will miss out on a few graphical goodies, and A LOT of speed.

Read more »